4 Star 0 Fork 0

OpenCloudOS Stream/blosc

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
blosc.spec 2.84 KB
一键复制 编辑 原始数据 按行查看 历史
ocs-bot 提交于 2023-09-08 22:10 . Rebuilt for OpenCloudOS Stream 23.09
Summary: High performance compressor optimized for binary data
Name: blosc
Version: 1.21.2
Release: 3%{?dist}
License: MIT
Source0: https://github.com/Blosc/c-blosc/archive/v%{version}/blosc-%{version}.tar.gz
URL: https://github.com/Blosc/c-blosc
BuildRequires: snappy-devel zlib-devel libzstd-devel
BuildRequires: gcc gcc-c++ cmake lz4-devel
%description
Blosc is a compression library designed to transmit data to the processor
cache faster than the traditional non-compressed memory fetch.
Compression ratios are not very high, but the decompression is very fast.
Blosc is meant not only to reduce the size of large datasets on-disk or
in-memory, but also to accelerate memory-bound computations.
%package devel
Summary: Header files and libraries for Blosc development
Requires: %{name} = %{version}-%{release}
%description devel
The blosc-devel package contains the header files and libraries needed
to develop programs that use the blosc meta-compressor.
%package bench
Summary: Benchmark for the Blosc compressor
Requires: %{name} = %{version}-%{release}
Requires: python3-matplotlib
%description bench
The blosc-bench package contains a benchmark suite which evaluates
the performance of Blosc, and compares it with memcpy.
%prep
%autosetup -n c-%{name}-%{version} -p1
rm -r internal-complibs/lz4* internal-complibs/zstd*
sed -i '1i set\(CMAKE_SKIP_RPATH true\)' bench/CMakeLists.txt
sed -i '1i set\(CMAKE_POSITION_INDEPENDENT_CODE TRUE\)' CMakeLists.txt
sed -i 's|lib/pkgconfig|%{_lib}/pkgconfig|' CMakeLists.txt
sed -i '1i #!/usr/bin/python3' bench/plot-speeds.py
%build
%cmake \
-DBUILD_STATIC:BOOL=OFF \
-DPREFER_EXTERNAL_LZ4:BOOL=ON \
-DTEST_INCLUDE_BENCH_SUITE:BOOL=OFF \
-DDEACTIVATE_SNAPPY:BOOL=OFF \
-DPREFER_EXTERNAL_ZLIB:BOOL=ON \
-DPREFER_EXTERNAL_ZSTD:BOOL=ON
%cmake_build
%install
%cmake_install
install -p bench/plot-speeds.py* -Dt %{buildroot}/%{_pkgdocdir}/bench/
install -pm 0644 bench/*.c %{buildroot}/%{_pkgdocdir}/bench
install -p %{_vpath_builddir}/bench/bench -D %{buildroot}/%{_bindir}/%{name}-bench
install -p bench/plot-speeds.py %{buildroot}/%{_bindir}/%{name}-plot-times
%check
export LD_LIBRARY_PATH=%{buildroot}%{_libdir}
%ctest
%files
%license LICENSES/*
%doc README.md ANNOUNCE.rst RELEASE_NOTES.rst README*.rst
%{_libdir}/libblosc.so.1*
%exclude %{_pkgdocdir}/bench/
%files devel
%{_libdir}/libblosc.so
%{_libdir}/pkgconfig/blosc.pc
%{_includedir}/blosc.h
%{_includedir}/blosc-export.h
%files bench
%{_pkgdocdir}/bench/*.c
%{_bindir}/%{name}-bench
%{_bindir}/%{name}-plot-times
%changelog
* Fri Sep 08 2023 OpenCloudOS Release Engineering <releng@opencloudos.tech> - 1.21.2-3
- Rebuilt for OpenCloudOS Stream 23.09
* Fri Apr 28 2023 OpenCloudOS Release Engineering <releng@opencloudos.tech> - 1.21.2-2
- Rebuilt for OpenCloudOS Stream 23.05
* Fri Apr 21 2023 cunshunxia <cunshunxia@tencent.com> - 1.21.2-1
- initial build
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/opencloudos-stream/blosc.git
git@gitee.com:opencloudos-stream/blosc.git
opencloudos-stream
blosc
blosc
master

搜索帮助

Cb406eda 1850385 E526c682 1850385