1 Star 0 Fork 53

openMajun/lcr

forked from openEuler/lcr 
加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
lcr.spec 3.66 KB
一键复制 编辑 原始数据 按行查看 历史
haozi007 提交于 2022-01-13 07:06 . refactor lcr build system
%global _version 2.1.0
%global _release 2
%global _inner_name isula_libutils
Name: lcr
Version: %{_version}
Release: %{_release}
URL: lcr
Source: lcr-2.0.tar.gz
Summary: Lightweight Container Runtime
Group: Applications/System
License: LGPLv2.1+
BuildRoot: %{_tmppath}/lcr-%{version}
BuildRequires: cmake gcc gcc-c++ git
BuildRequires: lxc
BuildRequires: lxc-devel
BuildRequires: zlib-devel yajl-devel gtest-devel
Requires: lxc yajl zlib
ExclusiveArch: x86_64 aarch64
%ifarch x86_64
Provides: liblcr.so()(64bit)
Provides: libisula_libutils.so()(64bit)
%endif
%ifarch aarch64
Provides: liblcr.so()(64bit)
Provides: libisula_libutils.so()(64bit)
%endif
%description
Containers are insulated areas inside a system, which have their own namespace
for filesystem, network, PID, IPC, CPU and memory allocation and which can be
created using the Control Group and Namespace features included in the Linux
kernel.
This package provides the lightweight container tools and library to control
lxc-based containers.
%package devel
Summary: Huawei container runtime, json and log C Library
Group: Libraries
ExclusiveArch: x86_64 aarch64
Requires: %{name} = %{version}-%{release}
%description devel
the %{name}-libs package contains libraries for running iSula applications.
%prep
%setup -c -n lcr-%{version}
%build
mkdir -p build
cd build
%cmake -DDEBUG=ON -DENABLE_UT=ON -DCMAKE_SKIP_RPATH=TRUE -DLIB_INSTALL_DIR=%{_libdir} ../
%make_build
%install
rm -rf %{buildroot}
cd build
mkdir -p %{buildroot}/{%{_libdir},%{_libdir}/pkgconfig,%{_includedir}/lcr,%{_bindir}}
install -m 0644 ./src/liblcr.so %{buildroot}/%{_libdir}/liblcr.so
install -m 0644 ./src/liblcr.a %{buildroot}/%{_libdir}/liblcr.a
install -m 0644 ./conf/lcr.pc %{buildroot}/%{_libdir}/pkgconfig/lcr.pc
install -m 0644 ../src/lcrcontainer.h %{buildroot}/%{_includedir}/lcr/lcrcontainer.h
chmod +x %{buildroot}/%{_libdir}/liblcr.so
install -m 0644 ./src/libisula_libutils.so %{buildroot}/%{_libdir}/libisula_libutils.so
install -m 0644 ./src/libisula_libutils.a %{buildroot}/%{_libdir}/libisula_libutils.a
install -d $RPM_BUILD_ROOT/%{_includedir}/%{_inner_name}
install -m 0644 ../build/json/*.h %{buildroot}/%{_includedir}/%{_inner_name}/
install -m 0644 ../src/json/*.h %{buildroot}/%{_includedir}/%{_inner_name}/
install -m 0644 ../third_party/log.h %{buildroot}/%{_includedir}/%{_inner_name}/log.h
install -m 0644 ../third_party/go_crc64.h %{buildroot}/%{_includedir}/%{_inner_name}/go_crc64.h
chmod +x %{buildroot}/%{_libdir}/libisula_libutils.so
find %{buildroot} -type f -name '*.la' -exec rm -f {} ';'
find %{buildroot} -name '*.a' -exec rm -f {} ';'
find %{buildroot} -name '*.cmake' -exec rm -f {} ';'
%clean
rm -rf %{buildroot}
%pre
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root,-)
%{_libdir}/*
%{_libdir}/pkgconfig/lcr.pc
%files devel
%defattr(-,root,root,-)
%{_includedir}/lcr/lcrcontainer.h
%{_includedir}/%{_inner_name}/*.h
%changelog
* Mon Sep 27 2021 wujing <wujing50@huawei.com> - 2.0.6-1
- Type:upgrade
- ID:NA
- SUG:NA
- DESC: upgrade version to 2.0.6
* Mon Aug 16 2021 wujing <wujing50@huawei.com> - 20210816.092741.gitacd2ee7d
- Type:enhancement
- ID:NA
- SUG:NA
- DESC: support cri exec resize
* Mon Jun 28 2021 wujing <wujing50@huawei.com> - 2.0.5-20210628.164318.gitb63048d2
- Type:enhancement
- ID:NA
- SUG:NA
- DESC: add git/gcc/gcc-c++ to build require
* Mon Aug 03 2020 openEuler Buildteam <buildteam@openeuler.org> - 2.0.2-20200803.120020.git8462c29a
- Type:enhancement
- ID:NA
- SUG:NA
- DESC: add debug packages
* Fri Apr 14 2017 Hui Wang <hw.huiwang@huawei.com> - 0.0.1
- Initial RPM release
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
C
1
https://gitee.com/majun-codecheck/lcr.git
git@gitee.com:majun-codecheck/lcr.git
majun-codecheck
lcr
lcr
master

搜索帮助