1 Star 0 Fork 11

lvxiaoqian/pybind11

forked from src-openEuler/pybind11 
加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
pybind11.spec 1.97 KB
一键复制 编辑 原始数据 按行查看 历史
lvxiaoqian 提交于 2022-05-26 03:12 . remove unnecessary buildrequires
%global debug_package %{nil}
%bcond_without tests
Name: pybind11
Version: 2.8.1
Release: 2
Summary: Seamless operability between C++11 and Python
License: BSD
URL: https://github.com/pybind/pybind11
Source0: https://github.com/pybind/pybind11/archive/refs/tags/v%{version}.tar.gz
BuildRequires: make cmake gcc-c++
BuildRequires: python3-devel python3-setuptools
#BuildRequires: python3-numpy python3-pytest
%description
pybind11 is a lightweight header-only library that exposes C++ types
in Python and vice versa, mainly to create Python bindings of existing
C++ code.
%package devel
Summary: Development headers for pybind11
Provides: %{name}-static = %{version}-%{release}
Requires: cmake
%description devel
This package contains the development headers for pybind11.
%package -n python3-%{name}
Summary: %{summary}
Requires: %{name}-devel%{?_isa} = %{version}-%{release}
%description -n python3-%{name}
pybind11 is a lightweight header-only library that exposes C++ types
in Python and vice versa, mainly to create Python bindings of existing
C++ code.
%prep
%autosetup -n %{name}-%{version} -p1
%build
pys=""
pys="$pys python3"
for py in $pys; do
mkdir $py
%cmake -B $py -DCMAKE_BUILD_TYPE=Debug -DPYTHON_EXECUTABLE=%{_bindir}/$py -DPYBIND11_INSTALL=TRUE -DUSE_PYTHON_INCLUDE_DIR=FALSE %{!?with_tests:-DPYBIND11_TEST=OFF}
%make_build -C $py
done
%py3_build
%check
#make -C python3 check %{?_smp_mflags}
%install
%make_install -C python3
PYBIND11_USE_CMAKE=true %py3_install "--install-purelib" "%{python3_sitearch}"
%files devel
%license LICENSE
%doc README.rst
%{_includedir}/pybind11/
%{_datadir}/cmake/pybind11/
%{_bindir}/pybind11-config
%files -n python3-%{name}
%{python3_sitearch}/%{name}/
%{python3_sitearch}/%{name}-%{version}-py%{python3_version}.egg-info
%changelog
* Tue May 31 2022 lvxiaoqian <xiaoqian@nj.iscas.ac.cn> - 2.8.1-2
- remove unnecessary buildrequires
* Sat Dec 11 2021 zhouwenpei <zhouwenpei1@huawei.com> - 2.8.1-1
- package init
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/lvxiaoqian/pybind11.git
git@gitee.com:lvxiaoqian/pybind11.git
lvxiaoqian
pybind11
pybind11
master

搜索帮助