1 Star 0 Fork 0

李萍/premake-git

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
PKGBUILD 1023 Bytes
一键复制 编辑 原始数据 按行查看 历史
李萍 提交于 2022-03-20 20:00 . update repo
# Maintainer: Simon Hauser <Simon-Hauser@outlook.de>
pkgname=premake-git
pkgver=5.0.0.alpha15.r101.g9b8b035a
pkgrel=1
pkgdesc='Simple build configuration and project generation tool using Lua'
arch=(i686 x86_64)
url='http://industriousone.com/premake'
license=(BSD)
depends=(glibc openssl)
makedepends=(git)
provides=(premake)
conflicts=(premake)
source=(git+https://github.com/premake/premake-core)
md5sums=('SKIP')
pkgver() {
cd premake-core
git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g;s/v//'
}
prepare() {
cd premake-core
git submodule init
git submodule update
}
build() {
cd premake-core
make -f Bootstrap.mak linux
bin/release/premake5 gmake
make config=release
}
check(){
cd premake-core
./bin/release/premake5 test
}
package() {
cd premake-core
install -Dm755 bin/release/premake5 "$pkgdir"/usr/bin/premake5
install -Dm755 packages/debian/premake.1 "$pkgdir"/usr/share/man/man1/premake5.1
install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
}
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/lipingEmmaSiguyi/premake-git.git
git@gitee.com:lipingEmmaSiguyi/premake-git.git
lipingEmmaSiguyi
premake-git
premake-git
master

搜索帮助