1 Star 0 Fork 0

王昊/git-core

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
git.spec 32.09 KB
一键复制 编辑 原始数据 按行查看 历史
王昊 提交于 2021-08-04 13:50 . init
123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861862863864865866867868869870871872873874875876877878879880881882883884885886887888889890891892893894895896897898899900901902903904905906907908909910911912913914915916917918919920921922923924925926927928929930931932933934935936937938939940941942943944945946947948949950951952953954955956957958959960961962963964965966967968969970971972973974975976977978979980981982983984985986987988989990991992993994995996997998999100010011002100310041005100610071008100910101011101210131014101510161017101810191020102110221023102410251026102710281029103010311032103310341035103610371038103910401041104210431044104510461047104810491050105110521053105410551056105710581059106010611062106310641065106610671068106910701071107210731074
# Pass --without docs to rpmbuild if you don't want the documentation
%bcond_without docs
# Pass --without tests to rpmbuild if you don't want to run the tests
%bcond_without tests
%global gitexecdir %{_libexecdir}/git-core
# Settings for Fedora >= 34
#%if 0%{?fedora} >= 34
%bcond_with emacs
#%else
#%bcond_without emacs
#%endif
# Settings for Fedora
#%if 0%{?fedora}
# linkchecker is not available on EL
%bcond_without linkcheck
#%else
#%bcond_with linkcheck
#%endif
# Settings for Fedora and EL >= 9
#%if 0%{?fedora} || 0%{?rhel} >= 9
%bcond_without asciidoctor
#%else
#%bcond_with asciidoctor
#%endif
# Settings for Fedora and EL > 7
#%if 0%{?fedora} || 0%{?rhel} > 7
%bcond_with python2
%bcond_without python3
%global gitweb_httpd_conf gitweb.conf
%global use_glibc_langpacks 1
%global use_perl_generators 1
%global use_perl_interpreter 1
#%else
#%bcond_without python2
#%bcond_with python3
#%global gitweb_httpd_conf git.conf
#%global use_glibc_langpacks 0
#%global use_perl_generators 0
#%global use_perl_interpreter 0
#%endif
# Settings for Fedora and EL >= 7
#%if 0%{?fedora} || 0%{?rhel} >= 7
%bcond_without libsecret
%global bashcomp_pkgconfig 1
%global bashcompdir %(pkg-config --variable=completionsdir bash-completion 2>/dev/null)
%global bashcomproot %(dirname %{bashcompdir} 2>/dev/null)
%global emacs_filesystem 1
%global use_new_rpm_filters 1
%global use_systemd 1
#%else
#%bcond_with libsecret
#%global bashcomp_pkgconfig 0
#%global bashcompdir %{_sysconfdir}/bash_completion.d
#%global bashcomproot %{bashcompdir}
#%global emacs_filesystem 0
#%global use_new_rpm_filters 0
#%global use_systemd 0
#%{!?_pkgdocdir: %global _pkgdocdir %{_docdir}/%{name}-%{version}}
#%endif
# Allow cvs subpackage to be toggled via --with/--without
# Disable cvs subpackage by default on EL > 7
#%if 0%{?rhel} > 7
%bcond_with cvs
#%else
#%bcond_without cvs
#%endif
# Allow p4 subpackage to be toggled via --with/--without
# Disable by default if we lack python2 support
#%if %{without python2}
%bcond_with p4
#%else
#%bcond_without p4
#%endif
# Hardening flags for EL-7
#%if 0%{?rhel} == 7
%global _hardened_build 1
#%endif
# Hardening flags for EL-6
#%if 0%{?rhel} == 6
%global build_cflags %{build_cflags} -fPIC -pie
%global build_ldflags -Wl,-z,relro -Wl,-z,now
#%endif
# Define for release candidates
#global rcrev .rc0
Name: git
Version: 2.31.1
Release: 1
Summary: Fast Version Control System
License: GPLv2
URL: https://git-scm.com/
Source0: https://www.kernel.org/pub/software/scm/git/%{?rcrev:testing/}%{name}-%{version}%{?rcrev}.tar.xz
Source1: https://www.kernel.org/pub/software/scm/git/%{?rcrev:testing/}%{name}-%{version}%{?rcrev}.tar.sign
# Junio C Hamano's key is used to sign git releases, it can be found in the
# junio-gpg-pub tag within git.
#
# (Note that the tagged blob in git contains a version of the key with an
# expired signing subkey. The subkey expiration has been extended on the
# public keyservers, but the blob in git has not been updated.)
#
# https://git.kernel.org/cgit/git/git.git/tag/?h=junio-gpg-pub
# https://git.kernel.org/cgit/git/git.git/blob/?h=junio-gpg-pub&id=7214aea37915ee2c4f6369eb9dea520aec7d855b
Source2: gpgkey-junio.asc
# Local sources begin at 10 to allow for additional future upstream sources
Source11: git.xinetd.in
Source12: git-gui.desktop
Source13: gitweb-httpd.conf
Source14: gitweb.conf.in
Source15: git@.service.in
Source16: git.socket
# Script to print test failure output (used in %%check)
Source99: print-failed-test-output
# https://bugzilla.redhat.com/490602
Patch0: git-cvsimport-Ignore-cvsps-2.2b1-Branches-output.patch
%if %{with docs}
# pod2man is needed to build Git.3pm
BuildRequires: %{_bindir}/pod2man
%if %{with asciidoctor}
BuildRequires: docbook5-style-xsl
BuildRequires: rubygem-asciidoctor
%else
BuildRequires: asciidoc >= 8.4.1
%endif
# endif with asciidoctor
BuildRequires: xmlto
%if %{with linkcheck}
BuildRequires: linkchecker
%endif
# endif with linkcheck
%endif
# endif with docs
BuildRequires: desktop-file-utils
BuildRequires: diffutils
%if %{with emacs}
BuildRequires: emacs-common
%endif
# endif emacs-common
%if 0%{?rhel} && 0%{?rhel} < 9
# Require epel-rpm-macros for the %%gpgverify macro on EL-7/EL-8, and
# %%build_cflags & %%build_ldflags on EL-7.
BuildRequires: epel-rpm-macros
%endif
# endif rhel < 9
BuildRequires: expat-devel
BuildRequires: findutils
BuildRequires: gawk
BuildRequires: gcc
BuildRequires: gettext
BuildRequires: gnupg2
BuildRequires: libcurl-devel
BuildRequires: make
BuildRequires: openssl-devel
BuildRequires: pcre2-devel
BuildRequires: perl(Error)
BuildRequires: perl(lib)
BuildRequires: perl(Test)
%if %{use_perl_generators}
BuildRequires: perl-generators
%endif
# endif use_perl_generators
%if %{use_perl_interpreter}
BuildRequires: perl-interpreter
%else
BuildRequires: perl
%endif
# endif use_perl_interpreter
%if %{bashcomp_pkgconfig}
BuildRequires: pkgconfig(bash-completion)
%endif
# endif bashcomp_pkgconfig
BuildRequires: sed
%if %{use_systemd}
# For macros
BuildRequires: systemd
%endif
# endif use_systemd
BuildRequires: tcl
BuildRequires: tk
BuildRequires: xz
BuildRequires: zlib-devel >= 1.2
%if %{with tests}
# Test suite requirements
BuildRequires: acl
%if 0%{?fedora} >= 27 || 0%{?rhel} > 7
# Needed by t5540-http-push-webdav.sh
BuildRequires: apr-util-bdb
%endif
# endif fedora >= 27
BuildRequires: bash
%if %{with cvs}
BuildRequires: cvs
BuildRequires: cvsps
%endif
# endif with cvs
%if %{use_glibc_langpacks}
# glibc-all-langpacks and glibc-langpack-is are needed for GETTEXT_LOCALE and
# GETTEXT_ISO_LOCALE test prereq's, glibc-langpack-en ensures en_US.UTF-8.
BuildRequires: glibc-all-langpacks
BuildRequires: glibc-langpack-en
BuildRequires: glibc-langpack-is
%endif
# endif use_glibc_langpacks
%if 0%{?fedora} && 0%{?fedora} < 30
BuildRequires: gnupg
%endif
# endif fedora < 30
%if 0%{?fedora} || 0%{?rhel} > 8
BuildRequires: gnupg2-smime
%endif
# endif fedora or el > 8
%if 0%{?fedora} || 0%{?rhel} == 6 || ( 0%{?rhel} >= 7 && ( "%{_arch}" == "ppc64le" || "%{_arch}" == "x86_64" ) )
BuildRequires: highlight
%endif
# endif fedora, el-6, or el7+ (ppc64le/x86_64)
BuildRequires: httpd
%if 0%{?fedora} && ! ( "%{_arch}" == "i386" || "%{_arch}" == "s390x" )
BuildRequires: jgit
%endif
# endif fedora (except i386 and s390x)
BuildRequires: mod_dav_svn
BuildRequires: perl(App::Prove)
BuildRequires: perl(CGI)
BuildRequires: perl(CGI::Carp)
BuildRequires: perl(CGI::Util)
BuildRequires: perl(DBD::SQLite)
BuildRequires: perl(Digest::MD5)
BuildRequires: perl(Fcntl)
BuildRequires: perl(File::Basename)
BuildRequires: perl(File::Copy)
BuildRequires: perl(File::Find)
BuildRequires: perl(filetest)
BuildRequires: perl(HTTP::Date)
BuildRequires: perl(IO::Pty)
BuildRequires: perl(JSON)
BuildRequires: perl(JSON::PP)
BuildRequires: perl(Mail::Address)
BuildRequires: perl(Memoize)
BuildRequires: perl(POSIX)
BuildRequires: perl(Term::ReadLine)
BuildRequires: perl(Test::More)
BuildRequires: perl(Time::HiRes)
#%if %{with python2}
#BuildRequires: python2-devel
#%endif
# endif with python2
#%if %{with python3}
BuildRequires: python3-devel
#%endif
# endif with python3
BuildRequires: subversion
BuildRequires: subversion-perl
BuildRequires: tar
BuildRequires: time
BuildRequires: zip
%endif
# endif with tests
Requires: git-core = %{version}-%{release}
Requires: git-core-doc = %{version}-%{release}
%if ! %{defined perl_bootstrap}
Requires: perl(Term::ReadKey)
%endif
# endif ! defined perl_bootstrap
Requires: perl-Git = %{version}-%{release}
%if %{with emacs} && %{emacs_filesystem} && %{defined _emacs_version}
Requires: emacs-filesystem >= %{_emacs_version}
%endif
# endif with emacs && emacs_filesystem
# Obsolete emacs-git if it's disabled
%if %{without emacs}
Obsoletes: emacs-git < %{?epoch:%{epoch}:}%{version}-%{release}
%endif
# endif without emacs
# Obsolete git-cvs if it's disabled
%if %{without cvs}
Obsoletes: git-cvs < %{?epoch:%{epoch}:}%{version}-%{release}
%endif
# endif without cvs
# Obsolete git-p4 if it's disabled
#%if %{without p4}
Obsoletes: git-p4 < %{?epoch:%{epoch}:}%{version}-%{release}
#%endif
# endif without p4
%description
Git is a fast, scalable, distributed revision control system with an
unusually rich command set that provides both high-level operations
and full access to internals.
The git rpm installs common set of tools which are usually using with
small amount of dependencies. To install all git packages, including
tools for integrating with other SCMs, install the git-all meta-package.
%package all
Summary: Meta-package to pull in all git tools
BuildArch: noarch
Requires: git = %{version}-%{release}
%if %{with libsecret}
Requires: git-credential-libsecret = %{version}-%{release}
%endif
# endif with libsecret
%if %{with cvs}
Requires: git-cvs = %{version}-%{release}
%endif
# endif with cvs
Requires: git-daemon = %{version}-%{release}
Requires: git-email = %{version}-%{release}
Requires: git-gui = %{version}-%{release}
#%if %{with p4}
#Requires: git-p4 = %{version}-%{release}
#%endif
# endif with p4
Requires: git-subtree = %{version}-%{release}
Requires: git-svn = %{version}-%{release}
Requires: git-instaweb = %{version}-%{release}
Requires: gitk = %{version}-%{release}
Requires: perl-Git = %{version}-%{release}
%if ! %{defined perl_bootstrap}
Requires: perl(Term::ReadKey)
%endif
# endif ! defined perl_bootstrap
%if %{with emacs} && ! %{emacs_filesystem}
Requires: emacs-git = %{version}-%{release}
%endif
# endif with emacs && ! emacs_filesystem
%description all
Git is a fast, scalable, distributed revision control system with an
unusually rich command set that provides both high-level operations
and full access to internals.
This is a dummy package which brings in all subpackages.
%package core
Summary: Core package of git with minimal functionality
Requires: less
Requires: openssh-clients
Requires: zlib >= 1.2
%description core
Git is a fast, scalable, distributed revision control system with an
unusually rich command set that provides both high-level operations
and full access to internals.
The git-core rpm installs really the core tools with minimal
dependencies. Install git package for common set of tools.
To install all git packages, including tools for integrating with
other SCMs, install the git-all meta-package.
%package core-doc
Summary: Documentation files for git-core
BuildArch: noarch
Requires: git-core = %{version}-%{release}
%description core-doc
Documentation files for git-core package including man pages.
%if %{with libsecret}
%package credential-libsecret
Summary: Git helper for accessing credentials via libsecret
BuildRequires: libsecret-devel
Requires: git = %{version}-%{release}
%description credential-libsecret
%{summary}.
%endif
# endif with libsecret
%if %{with cvs}
%package cvs
Summary: Git tools for importing CVS repositories
BuildArch: noarch
Requires: git = %{version}-%{release}
Requires: cvs
Requires: cvsps
Requires: perl(DBD::SQLite)
%description cvs
%{summary}.
%endif
# endif with cvs
%package daemon
Summary: Git protocol daemon
Requires: git-core = %{version}-%{release}
%if %{use_systemd}
Requires: systemd
Requires(post): systemd
Requires(preun): systemd
Requires(postun): systemd
%else
Requires: xinetd
%endif
# endif use_systemd
%description daemon
The git daemon for supporting git:// access to git repositories
%package email
Summary: Git tools for sending patches via email
BuildArch: noarch
Requires: git = %{version}-%{release}
Requires: perl(Authen::SASL)
Requires: perl(Net::SMTP::SSL)
%description email
%{summary}.
%if %{with emacs} && ! %{emacs_filesystem}
%package -n emacs-git
Summary: Git version control system support for Emacs
Requires: git = %{version}-%{release}
BuildArch: noarch
Requires: emacs(bin) >= %{_emacs_version}
Obsoletes: emacs-git-el < 2.18.0-0.0
Provides: emacs-git-el = %{version}-%{release}
%description -n emacs-git
%{summary}.
%endif
# endif with emacs && ! emacs_filesystem
%package -n gitk
Summary: Git repository browser
BuildArch: noarch
Requires: git = %{version}-%{release}
Requires: git-gui = %{version}-%{release}
Requires: tk >= 8.4
%description -n gitk
%{summary}.
%package -n gitweb
Summary: Simple web interface to git repositories
BuildArch: noarch
Requires: git = %{version}-%{release}
%description -n gitweb
%{summary}.
%package gui
Summary: Graphical interface to Git
BuildArch: noarch
Requires: gitk = %{version}-%{release}
Requires: tk >= 8.4
%description gui
%{summary}.
%package instaweb
Summary: Repository browser in gitweb
BuildArch: noarch
Requires: git = %{version}-%{release}
Requires: gitweb = %{version}-%{release}
%if 0%{?rhel} >= 9
Requires: httpd
%else
Requires: lighttpd
%endif
%description instaweb
A simple script to set up gitweb and a web server for browsing the local
repository.
#%if %{with p4}
#%package p4
#Summary: Git tools for working with Perforce depots
#BuildArch: noarch
#BuildRequires: python2-devel
#Requires: git = %{version}-%{release}
#%description p4
#%{summary}.
#%endif
# endif with p4
%package -n perl-Git
Summary: Perl interface to Git
BuildArch: noarch
Requires: git = %{version}-%{release}
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
%description -n perl-Git
%{summary}.
%package -n perl-Git-SVN
Summary: Perl interface to Git::SVN
BuildArch: noarch
Requires: git = %{version}-%{release}
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
%description -n perl-Git-SVN
%{summary}.
%package subtree
Summary: Git tools to merge and split repositories
Requires: git-core = %{version}-%{release}
%description subtree
Git subtrees allow subprojects to be included within a subdirectory
of the main project, optionally including the subproject's entire
history.
%package svn
Summary: Git tools for interacting with Subversion repositories
BuildArch: noarch
Requires: git = %{version}-%{release}
Requires: perl(Digest::MD5)
%if ! %{defined perl_bootstrap}
Requires: perl(Term::ReadKey)
%endif
# endif ! defined perl_bootstrap
Requires: subversion
%description svn
%{summary}.
%prep
# Verify GPG signatures
#xz -dc '%{SOURCE0}' | %{gpgverify} --keyring='%{SOURCE2}' --signature='%{SOURCE1}' --data=-
%autosetup -p1 -n %{name}-%{version}%{?rcrev}
# Install print-failed-test-output script
install -p -m 755 %{SOURCE99} print-failed-test-output
# Remove git-archimport from command list
sed -i '/^git-archimport/d' command-list.txt
%if %{without cvs}
# Remove git-cvs* from command list
sed -i '/^git-cvs/d' command-list.txt
%endif
# endif without cvs
#%if %{without p4}
# Remove git-p4 from command list
sed -i '/^git-p4/d' command-list.txt
#%endif
# endif without p4
# Use these same options for every invocation of 'make'.
# Otherwise it will rebuild in %%install due to flags changes.
# Pipe to tee to aid confirmation/verification of settings.
cat << \EOF | tee config.mak
V = 1
CFLAGS = %{build_cflags}
LDFLAGS = %{build_ldflags}
NEEDS_CRYPTO_WITH_SSL = 1
USE_LIBPCRE = 1
ETC_GITCONFIG = %{_sysconfdir}/gitconfig
INSTALL_SYMLINKS = 1
GITWEB_PROJECTROOT = %{_localstatedir}/lib/git
GNU_ROFF = 1
NO_PERL_CPAN_FALLBACKS = 1
%if %{with python2}
PYTHON_PATH = %{__python2}
%else
NO_PYTHON = 1
%endif
# endif with python2
%if %{with asciidoctor}
USE_ASCIIDOCTOR = 1
%endif
# endif with asciidoctor
htmldir = %{?_pkgdocdir}%{!?_pkgdocdir:%{_docdir}/%{name}-%{version}}
prefix = %{_prefix}
perllibdir = %{perl_vendorlib}
gitwebdir = %{_localstatedir}/www/git
# Test options
DEFAULT_TEST_TARGET = prove
GIT_PROVE_OPTS = --verbose --normalize %{?_smp_mflags} --formatter=TAP::Formatter::File
GIT_TEST_OPTS = -x --verbose-log
EOF
# Filter bogus perl requires
# packed-refs comes from a comment in contrib/hooks/update-paranoid
%if %{use_new_rpm_filters}
%{?perl_default_filter}
%global __requires_exclude %{?__requires_exclude:%__requires_exclude|}perl\\(packed-refs\\)
%if ! %{defined perl_bootstrap}
%global __requires_exclude %{?__requires_exclude:%__requires_exclude|}perl\\(Term::ReadKey\\)
%endif
# endif ! defined perl_bootstrap
%else
cat << \EOF > %{name}-req
#!/bin/sh
%{__perl_requires} $* |\
sed -e '/perl(packed-refs)/d'
EOF
%global __perl_requires %{_builddir}/%{name}-%{version}%{?rcrev}/%{name}-req
chmod +x %{__perl_requires}
%endif
# endif use_new_rpm_filters
# Remove Git::LoadCPAN to ensure we use only system perl modules. This also
# allows the dependencies to be automatically processed by rpm.
rm -rf perl/Git/LoadCPAN{.pm,/}
grep -rlZ '^use Git::LoadCPAN::' | xargs -r0 sed -i 's/Git::LoadCPAN:://g'
# Update gitweb default home link string
sed -i 's@"++GITWEB_HOME_LINK_STR++"@$ENV{"SERVER_NAME"} ? "git://" . $ENV{"SERVER_NAME"} : "projects"@' \
gitweb/gitweb.perl
# Move contrib/{contacts,subtree} docs to Documentation so they build with the
# proper asciidoc/docbook/xmlto options
mv contrib/{contacts,subtree}/git-*.txt Documentation/
%build
# Improve build reproducibility
export TZ=UTC
export SOURCE_DATE_EPOCH=$(date -r version +%%s 2>/dev/null)
%make_build all %{?with_docs:doc}
%make_build -C contrib/contacts/ all
%if %{with libsecret}
%make_build -C contrib/credential/libsecret/
%endif
# endif with libsecret
%make_build -C contrib/credential/netrc/
%make_build -C contrib/diff-highlight/
%make_build -C contrib/subtree/ all
# Fix shebang in a few places to silence rpmlint complaints
%if %{with python2}
sed -i -e '1s@#! */usr/bin/env python$@#!%{__python2}@' \
contrib/fast-import/import-zips.py \
contrib/hooks/multimail/git_multimail.py \
contrib/hooks/multimail/migrate-mailhook-config \
contrib/hooks/multimail/post-receive.example
%else
# Remove contrib/fast-import/import-zips.py which requires python2.
rm -rf contrib/fast-import/import-zips.py
%endif
# endif with python2
# The multimail hook is installed with git. Use python3 to avoid an
# unnecessary python2 dependency, if possible. Also fix contrib/hg-to-git
# while here.
%if %{with python3}
sed -i -e '1s@#!\( */usr/bin/env python\|%{__python2}\)$@#!%{__python3}@' \
contrib/hg-to-git/hg-to-git.py \
contrib/hooks/multimail/git_multimail.py \
contrib/hooks/multimail/migrate-mailhook-config \
contrib/hooks/multimail/post-receive.example
%endif
# endif with python3
%install
%make_install %{?with_docs:install-doc}
%make_install -C contrib/contacts
%if %{with emacs}
%global elispdir %{_emacs_sitelispdir}/git
pushd contrib/emacs >/dev/null
for el in *.el ; do
# Note: No byte-compiling is done. These .el files are one-line stubs
# which only serve to point users to better alternatives.
install -Dpm 644 $el %{buildroot}%{elispdir}/$el
rm -f $el # clean up to avoid cruft in git-core-doc
done
popd >/dev/null
%endif
# endif with emacs
%if %{with libsecret}
install -pm 755 contrib/credential/libsecret/git-credential-libsecret \
%{buildroot}%{gitexecdir}
%endif
# endif with libsecret
install -pm 755 contrib/credential/netrc/git-credential-netrc \
%{buildroot}%{gitexecdir}
# temporarily move contrib/credential/netrc aside to prevent it from being
# deleted in the docs preparation, so the tests can be run in %%check
mv contrib/credential/netrc .
%make_install -C contrib/subtree
mkdir -p %{buildroot}%{_sysconfdir}/httpd/conf.d
install -pm 0644 %{SOURCE13} %{buildroot}%{_sysconfdir}/httpd/conf.d/%{gitweb_httpd_conf}
sed "s|@PROJECTROOT@|%{_localstatedir}/lib/git|g" \
%{SOURCE14} > %{buildroot}%{_sysconfdir}/gitweb.conf
# install contrib/diff-highlight and clean up to avoid cruft in git-core-doc
install -Dpm 0755 contrib/diff-highlight/diff-highlight \
%{buildroot}%{_datadir}/git-core/contrib/diff-highlight
rm -rf contrib/diff-highlight/{Makefile,diff-highlight,*.perl,t}
# Clean up contrib/subtree to avoid cruft in the git-core-doc docdir
rm -rf contrib/subtree/{INSTALL,Makefile,git-subtree*,t}
# git-archimport is not supported
find %{buildroot} Documentation -type f -name 'git-archimport*' -exec rm -f {} ';'
%if %{without cvs}
# Remove git-cvs* and gitcvs*
find %{buildroot} Documentation \( -type f -o -type l \) \
\( -name 'git-cvs*' -o -name 'gitcvs*' \) -exec rm -f {} ';'
%endif
# endif without cvs
#%if %{without p4}
# Remove git-p4* and mergetools/p4merge
find %{buildroot} Documentation -type f -name 'git-p4*' -exec rm -f {} ';'
rm -f %{buildroot}%{gitexecdir}/mergetools/p4merge
#%endif
# endif without p4
# Remove unneeded git-remote-testsvn so git-svn can be noarch
rm -f %{buildroot}%{gitexecdir}/git-remote-testsvn
exclude_re="archimport|email|git-(citool|credential-libsecret|cvs|daemon|gui|instaweb|p4|subtree|svn)|gitk|gitweb|p4merge"
(find %{buildroot}{%{_bindir},%{_libexecdir}} -type f -o -type l | grep -vE "$exclude_re" | sed -e s@^%{buildroot}@@) > bin-man-doc-files
(find %{buildroot}{%{_bindir},%{_libexecdir}} -mindepth 1 -type d | grep -vE "$exclude_re" | sed -e 's@^%{buildroot}@%dir @') >> bin-man-doc-files
(find %{buildroot}%{perl_vendorlib} -type f | sed -e s@^%{buildroot}@@) > perl-git-files
(find %{buildroot}%{perl_vendorlib} -mindepth 1 -type d | sed -e 's@^%{buildroot}@%dir @') >> perl-git-files
# Split out Git::SVN files
grep Git/SVN perl-git-files > perl-git-svn-files
sed -i "/Git\/SVN/ d" perl-git-files
%if %{with docs}
(find %{buildroot}%{_mandir} -type f | grep -vE "$exclude_re|Git" | sed -e s@^%{buildroot}@@ -e 's/$/*/' ) >> bin-man-doc-files
%else
rm -rf %{buildroot}%{_mandir}
%endif
# endif with docs
mkdir -p %{buildroot}%{_localstatedir}/lib/git
%if %{use_systemd}
install -Dp -m 0644 %{SOURCE16} %{buildroot}%{_unitdir}/git.socket
perl -p \
-e "s|\@GITEXECDIR\@|%{gitexecdir}|g;" \
-e "s|\@BASE_PATH\@|%{_localstatedir}/lib/git|g;" \
%{SOURCE15} > %{buildroot}%{_unitdir}/git@.service
%else
mkdir -p %{buildroot}%{_sysconfdir}/xinetd.d
perl -p \
-e "s|\@GITEXECDIR\@|%{gitexecdir}|g;" \
-e "s|\@BASE_PATH\@|%{_localstatedir}/lib/git|g;" \
%{SOURCE11} > %{buildroot}%{_sysconfdir}/xinetd.d/git
%endif
# endif use_systemd
# Setup bash completion
install -Dpm 644 contrib/completion/git-completion.bash %{buildroot}%{bashcompdir}/git
ln -s git %{buildroot}%{bashcompdir}/gitk
# Install tcsh completion
mkdir -p %{buildroot}%{_datadir}/git-core/contrib/completion
install -pm 644 contrib/completion/git-completion.tcsh \
%{buildroot}%{_datadir}/git-core/contrib/completion/
# Drop .py extension from git_multimail to avoid byte-compiling
mv contrib/hooks/multimail/git_multimail{.py,}
# Move contrib/hooks out of %%docdir
mkdir -p %{buildroot}%{_datadir}/git-core/contrib
mv contrib/hooks %{buildroot}%{_datadir}/git-core/contrib
pushd contrib > /dev/null
ln -s ../../../git-core/contrib/hooks
popd > /dev/null
# Install git-prompt.sh
mkdir -p %{buildroot}%{_datadir}/git-core/contrib/completion
install -pm 644 contrib/completion/git-prompt.sh \
%{buildroot}%{_datadir}/git-core/contrib/completion/
# install git-gui .desktop file
desktop-file-install --dir=%{buildroot}%{_datadir}/applications %{SOURCE12}
# symlink git-citool to git-gui if they are identical
pushd %{buildroot}%{gitexecdir} >/dev/null
if cmp -s git-gui git-citool 2>/dev/null; then
ln -svf git-gui git-citool
fi
popd >/dev/null
# find translations
%find_lang %{name} %{name}.lang
cat %{name}.lang >> bin-man-doc-files
# quiet some rpmlint complaints
chmod -R g-w %{buildroot}
chmod a-x %{buildroot}%{gitexecdir}/git-mergetool--lib
# These files probably are not needed
find . -regex '.*/\.\(git\(attributes\|ignore\)\|perlcriticrc\)' -delete
chmod a-x Documentation/technical/api-index.sh
find contrib -type f -print0 | xargs -r0 chmod -x
# Split core files
not_core_re="git-(add--interactive|contacts|credential-netrc|filter-branch|instaweb|request-pull|send-mail)|gitweb"
grep -vE "$not_core_re|%{_mandir}" bin-man-doc-files > bin-files-core
touch man-doc-files-core
%if %{with docs}
grep -vE "$not_core_re" bin-man-doc-files | grep "%{_mandir}" > man-doc-files-core
%endif
# endif with docs
grep -E "$not_core_re" bin-man-doc-files > bin-man-doc-git-files
##### DOC
# place doc files into %%{_pkgdocdir} and split them into expected packages
# contrib
not_core_doc_re="(git-(cvs|gui|citool|daemon|instaweb|subtree))|p4|svn|email|gitk|gitweb"
mkdir -p %{buildroot}%{_pkgdocdir}/
cp -pr CODE_OF_CONDUCT.md README.md Documentation/*.txt Documentation/RelNotes contrib %{buildroot}%{_pkgdocdir}/
# Remove contrib/ files/dirs which have nothing useful for documentation
rm -rf %{buildroot}%{_pkgdocdir}/contrib/{contacts,credential}/
cp -p gitweb/INSTALL %{buildroot}%{_pkgdocdir}/INSTALL.gitweb
cp -p gitweb/README %{buildroot}%{_pkgdocdir}/README.gitweb
%if %{with docs}
cp -pr Documentation/*.html Documentation/docbook-xsl.css %{buildroot}%{_pkgdocdir}/
cp -pr Documentation/{howto,technical} %{buildroot}%{_pkgdocdir}/
find %{buildroot}%{_pkgdocdir}/{howto,technical} -type f \
|grep -o "%{_pkgdocdir}.*$" >> man-doc-files-core
%endif
# endif with docs
{
find %{buildroot}%{_pkgdocdir} -type f -maxdepth 1 \
| grep -o "%{_pkgdocdir}.*$" \
| grep -vE "$not_core_doc_re"
find %{buildroot}%{_pkgdocdir}/{contrib,RelNotes} -type f \
| grep -o "%{_pkgdocdir}.*$"
find %{buildroot}%{_pkgdocdir} -type d | grep -o "%{_pkgdocdir}.*$" \
| sed "s/^/\%dir /"
} >> man-doc-files-core
##### #DOC
%check
%if %{without tests}
echo "*** Skipping tests"
exit 0
%endif
# endif without tests
%if %{with docs} && %{with linkcheck}
# Test links in HTML documentation
find %{buildroot}%{_pkgdocdir} -name "*.html" -print0 | xargs -r0 linkchecker
%endif
# endif with docs && with linkcheck
# Tests to skip on all releases and architectures
GIT_SKIP_TESTS=""
#%ifarch aarch64 %{arm} %{power64}
# Skip tests which fail on aarch64, arm, and ppc
#
# The following 2 tests use run_with_limited_cmdline, which calls ulimit -s 128
# to limit the maximum stack size.
# t5541.35 'push 2000 tags over http'
# t5551.25 'clone the 2,000 tag repo to check OS command line overflow'
GIT_SKIP_TESTS="$GIT_SKIP_TESTS t5541.35 t5551.25"
#%endif
# endif aarch64 %%{arm} %%{power64}
#%ifarch %{power64}
# Skip tests which fail on ppc
#
# t9115-git-svn-dcommit-funky-renames is disabled because it frequently fails.
# The port it uses (9115) is already in use. It is unclear if this is
# due to an issue in the test suite or a conflict with some other process on
# the build host. It only appears to occur on ppc-arches.
GIT_SKIP_TESTS="$GIT_SKIP_TESTS t9115"
#%endif
# endif %%{power64}
export GIT_SKIP_TESTS
# Set LANG so various UTF-8 tests are run
export LANG=en_US.UTF-8
# Explicitly enable tests which may be skipped opportunistically
# (Check for variables set via test_tristate in the test suite)
export GIT_SVN_TEST_HTTPD=true
export GIT_TEST_GIT_DAEMON=true
export GIT_TEST_HTTPD=true
export GIT_TEST_SVNSERVE=true
# Create tmpdir for test output and update GIT_TEST_OPTS
# Also update GIT-BUILD-OPTIONS to keep make from any needless rebuilding
testdir=$(mktemp -d -p /tmp git-t.XXXX)
sed -i "s@^GIT_TEST_OPTS = .*@& --root=$testdir@" config.mak
touch -r GIT-BUILD-OPTIONS ts
sed -i "s@\(GIT_TEST_OPTS='.*\)'@\1 --root=$testdir'@" GIT-BUILD-OPTIONS
touch -r ts GIT-BUILD-OPTIONS
# Run the tests
%__make test || ./print-failed-test-output
# Run contrib/credential/netrc tests
mkdir -p contrib/credential
mv netrc contrib/credential/
%make_build -C contrib/credential/netrc/ test || \
%make_build -C contrib/credential/netrc/ testverbose
# Clean up test dir
rmdir --ignore-fail-on-non-empty "$testdir"
%if %{use_systemd}
%post daemon
%systemd_post git.socket
%preun daemon
%systemd_preun git.socket
%postun daemon
%systemd_postun_with_restart git.socket
%endif
# endif use_systemd
%files -f bin-man-doc-git-files
%if %{with emacs} && %{emacs_filesystem}
%{elispdir}
%endif
# endif with emacs && emacs_filesystem
%{_datadir}/git-core/contrib/diff-highlight
%{_datadir}/git-core/contrib/hooks/multimail
%{_datadir}/git-core/contrib/hooks/update-paranoid
%{_datadir}/git-core/contrib/hooks/setgitperms.perl
%{_datadir}/git-core/templates/hooks/fsmonitor-watchman.sample
%{_datadir}/git-core/templates/hooks/pre-rebase.sample
%{_datadir}/git-core/templates/hooks/prepare-commit-msg.sample
%files all
# No files for you!
%files core -f bin-files-core
#NOTE: this is only use of the %%doc macro in this spec file and should not
# be used elsewhere
%{!?_licensedir:%global license %doc}
%license COPYING
# exclude is best way here because of troubles with symlinks inside git-core/
%exclude %{_datadir}/git-core/contrib/diff-highlight
%exclude %{_datadir}/git-core/contrib/hooks/multimail
%exclude %{_datadir}/git-core/contrib/hooks/update-paranoid
%exclude %{_datadir}/git-core/contrib/hooks/setgitperms.perl
%exclude %{_datadir}/git-core/templates/hooks/fsmonitor-watchman.sample
%exclude %{_datadir}/git-core/templates/hooks/pre-rebase.sample
%exclude %{_datadir}/git-core/templates/hooks/prepare-commit-msg.sample
%{bashcomproot}
%{_datadir}/git-core/
%files core-doc -f man-doc-files-core
%if 0%{?rhel} && 0%{?rhel} <= 7
# .py files are only bytecompiled on EL <= 7
%exclude %{_pkgdocdir}/contrib/*/*.py[co]
%endif
# endif rhel <= 7
%{_pkgdocdir}/contrib/hooks
%if %{with libsecret}
%files credential-libsecret
%defattr(-,root,root)
%{gitexecdir}/git-credential-libsecret
%endif
# endif with libsecret
%if %{with cvs}
%files cvs
%{_pkgdocdir}/*git-cvs*.txt
%{_bindir}/git-cvsserver
%{gitexecdir}/*cvs*
%{?with_docs:%{_mandir}/man1/*cvs*.1*}
%{?with_docs:%{_pkgdocdir}/*git-cvs*.html}
%endif
# endif with cvs
%files daemon
%{_pkgdocdir}/git-daemon*.txt
%if %{use_systemd}
%{_unitdir}/git.socket
%{_unitdir}/git@.service
%else
%config(noreplace)%{_sysconfdir}/xinetd.d/git
%endif
# endif use_systemd
%{gitexecdir}/git-daemon
%{_localstatedir}/lib/git
%{?with_docs:%{_mandir}/man1/git-daemon*.1*}
%{?with_docs:%{_pkgdocdir}/git-daemon*.html}
%if %{with emacs} && ! %{emacs_filesystem}
%files -n emacs-git
%{_pkgdocdir}/contrib/emacs/README
%{elispdir}
%endif
# endif with emacs && ! emacs_filesystem
%files email
%{_pkgdocdir}/*email*.txt
%{gitexecdir}/*email*
%{?with_docs:%{_mandir}/man1/*email*.1*}
%{?with_docs:%{_pkgdocdir}/*email*.html}
%files -n gitk
%{_pkgdocdir}/*gitk*.txt
%{_bindir}/*gitk*
%{_datadir}/gitk
%{?with_docs:%{_mandir}/man1/*gitk*.1*}
%{?with_docs:%{_pkgdocdir}/*gitk*.html}
%files -n gitweb
%{_pkgdocdir}/*.gitweb
%{_pkgdocdir}/gitweb*.txt
%{?with_docs:%{_mandir}/man1/gitweb.1*}
%{?with_docs:%{_mandir}/man5/gitweb.conf.5*}
%{?with_docs:%{_pkgdocdir}/gitweb*.html}
%config(noreplace)%{_sysconfdir}/gitweb.conf
%config(noreplace)%{_sysconfdir}/httpd/conf.d/%{gitweb_httpd_conf}
%{_localstatedir}/www/git/
%files gui
%{gitexecdir}/git-gui*
%{gitexecdir}/git-citool
%{_datadir}/applications/*git-gui.desktop
%{_datadir}/git-gui/
%{_pkgdocdir}/git-gui.txt
%{_pkgdocdir}/git-citool.txt
%{?with_docs:%{_mandir}/man1/git-gui.1*}
%{?with_docs:%{_pkgdocdir}/git-gui.html}
%{?with_docs:%{_mandir}/man1/git-citool.1*}
%{?with_docs:%{_pkgdocdir}/git-citool.html}
%files instaweb
%defattr(-,root,root)
%{gitexecdir}/git-instaweb
%{_pkgdocdir}/git-instaweb.txt
%{?with_docs:%{_mandir}/man1/git-instaweb.1*}
%{?with_docs:%{_pkgdocdir}/git-instaweb.html}
#%if %{with p4}
#%files p4
#%{gitexecdir}/*p4*
#%{gitexecdir}/mergetools/p4merge
#%{_pkgdocdir}/*p4*.txt
#%{?with_docs:%{_mandir}/man1/*p4*.1*}
#%{?with_docs:%{_pkgdocdir}/*p4*.html}
#%endif
# endif with p4
%files -n perl-Git -f perl-git-files
%{?with_docs:%{_mandir}/man3/Git.3pm*}
%files -n perl-Git-SVN -f perl-git-svn-files
%files subtree
%{gitexecdir}/git-subtree
%{_pkgdocdir}/git-subtree.txt
%{?with_docs:%{_mandir}/man1/git-subtree.1*}
%{?with_docs:%{_pkgdocdir}/git-subtree.html}
%files svn
%{gitexecdir}/git-svn
%{_pkgdocdir}/git-svn.txt
%{?with_docs:%{_mandir}/man1/git-svn.1*}
%{?with_docs:%{_pkgdocdir}/git-svn.html}
%changelog
* Sat Mar 27 2021 Todd Zullinger <tmz@pobox.com> - 2.31.1-1
- update to 2.31.1
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/kylinhao/git-core.git
git@gitee.com:kylinhao/git-core.git
kylinhao
git-core
git-core
master

搜索帮助