1 Star 0 Fork 0

jackchanel/HDUOJ_P11

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
克隆/下载
2039 三角形.cpp 708 Bytes
一键复制 编辑 原始数据 按行查看 历史
jackchanel 提交于 2023-03-23 22:10 . 两边之和大于第三边
// Problem Description 给定三条边,请你判断一下能不能组成一个三角形。
// Input 输入数据第一行包含一个数M,接下有M行,每行一个实例,包含三个正数A,B,C。其中A,B,C <1000;
// Output 对于每个测试实例,如果三条边长A,B,C能组成三角形的话,输出YES,否则NO。
// Sample Input
// 2
// 1 2 3
// 2 2 2
// Sample Output
// NO
// YES
#include <iostream>
using namespace std;
int main(void)
{
int A, B, C, M;
cin >> M;
while (M--)
{
cin >> A >> B >> C;
if (A + B > C && A + C > B && B + C > A)
cout << "YES" << endl;
else
cout << "NO" << endl;
}
return 0;
}
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/jackchanel/hduoj.git
git@gitee.com:jackchanel/hduoj.git
jackchanel
hduoj
HDUOJ_P11
master

搜索帮助