1 Star 0 Fork 0

jackchanel/HDUOJ_P11

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
克隆/下载
2019 数列有序.cpp 1.08 KB
一键复制 编辑 原始数据 按行查看 历史
jackchanel 提交于 2023-03-22 16:13 . 再写几题
// Problem Description 有n(n<=100)个整数,已经按照从小到大顺序排列好,现在另外给一个整数x,请将该数插入到序列中,并使新的序列仍然有序。
// Input 输入数据包含多个测试实例,每组数据由两行组成,第一行是n和m,第二行是已经有序的n个数的数列。n和m同时为0标示输入数据的结束,本行不做处理。
// Output 对于每个测试实例,输出插入新的元素后的数列。
// Sample Input
// 3 3
// 1 2 4
// 0 0
// Sample Output
// 1 2 3 4
#include <iostream>
using namespace std;
int main()
{
int length, target;
while (scanf("%d%d", &length, &target), length || target)
{
bool canInsert = true;
for (int i = 0; i < length; i++)
{
int u, loc = 0;
cin >> u;
if (target > u)
loc = i;
if (target < u && canInsert)
{
cout << target << " ";
canInsert = false;
}
cout << u << " ";
}
cout << endl;
}
return 0;
}
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/jackchanel/hduoj.git
git@gitee.com:jackchanel/hduoj.git
jackchanel
hduoj
HDUOJ_P11
master

搜索帮助