代码拉取完成,页面将自动刷新
// Problem Description 对于给定的一个字符串,统计其中数字字符出现的次数。
// Input 输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。
// Output 对于每个测试实例,输出该串中数值的个数,每个输出占一行。
// Sample Input
// 2
// asdfasdf123123asdfasdf
// asdf111111111asdfasdfasdf
// Sample Output
// 6
// 9
#include <iostream>
using namespace std;
bool isNum(char s)
{
if (s - '0' >= 0 && s - '0' <= 9)
return true;
return false;
}
int main()
{
int n;
cin >> n;
while (n--)
{
int cnt = 0;
string row;
cin >> row;
for (auto i : row)
{
if (isNum(i))
cnt++;
}
cout << cnt << endl;
}
return 0;
}
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。