1 Star 0 Fork 0

jackchanel/HDUOJ_P11

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
克隆/下载
2014 青年歌手大奖赛.cpp 1.02 KB
一键复制 编辑 原始数据 按行查看 历史
jackchanel 提交于 2023-03-22 11:53 . 简单写几题
// Problem Description 青年歌手大奖赛中,评委会给参赛选手打分。选手得分规则为去掉一个最高分和一个最低分,然后计算平均得分,请编程输出某选手的得分。
// Input 输入数据有多组,每组占一行,每行的第一个数是n(2<n<100),表示评委的人数,然后是n个评委的打分。
// Output 对于每组输入数据,输出选手的得分,结果保留2位小数,每组输出占一行。
// Sample Input
// 3 99 98 97
// 4 100 99 98 97
// Sample Output
// 98.00
// 98.50
#include <iostream>
using namespace std;
int main()
{
int n;
while (cin >> n)
{
int min = INT16_MAX;
int max = INT16_MIN;
int score, sum = 0;
for (int i = 0; i < n; i++)
{
cin >> score;
if (score > max)
max = score;
if (score < min)
min = score;
sum += score;
}
printf("%.2lf\n", (double)(sum - max - min) / (n - 2.0));
}
return 0;
}
Loading...
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/jackchanel/hduoj.git
git@gitee.com:jackchanel/hduoj.git
jackchanel
hduoj
HDUOJ_P11
master

搜索帮助