代码拉取完成,页面将自动刷新
同步操作将从 OpenCloudOS Stream/python-tpm2-pytss 强制同步,此操作会覆盖自 Fork 仓库以来所做的任何修改,且无法恢复!!!
确定后同步将在后台操作,完成时将刷新页面,请耐心等待。
%global srcname tpm2-pytss
# open this flag in the future
%bcond_with testsuite
Summary: TPM 2.0 TSS Bindings for Python
Name: python-%{srcname}
Version: 1.2.0
Release: 7%{?dist}
License: BSD-2-Clause
URL: https://github.com/tpm2-software/tpm2-pytss
Source: %{pypi_source %{srcname}}
Patch3001: python-tpm2-pytss-1.2.0-openssl.patch
BuildRequires: python3-devel python3-pytest python3-pytest-xdist tpm2-tss-devel gcc
%if %{with testsuite}
BuildRequires: swtpm tpm2-tools
%endif
%description
TPM2 TSS Python bindings for Enhanced System API (ESYS), Feature API (FAPI), Marshaling (MU),
TCTI Loader (TCTILdr) and RC Decoding (rcdecode) libraries. It also contains utility methods
for wrapping keys to TPM 2.0 data structures for importation into the TPM, unwrapping keys
and exporting them from the TPM, TPM-less makecredential command and name calculations, TSS2
PEM Key format support, importing Keys from PEM, DER and SSH formats, conversion from tpm2-tools
based command line strings and loading tpm2-tools context files.
%package -n python3-%{srcname}
Summary: %{summary}
%description -n python3-%{srcname}
TPM2 TSS Python bindings for Enhanced System API (ESYS), Feature API (FAPI), Marshaling (MU),
TCTI Loader (TCTILdr) and RC Decoding (rcdecode) libraries. It also contains utility methods
for wrapping keys to TPM 2.0 data structures for importation into the TPM, unwrapping keys
and exporting them from the TPM, TPM-less makecredential command and name calculations, TSS2
PEM Key format support, importing Keys from PEM, DER and SSH formats, conversion from tpm2-tools
based command line strings and loading tpm2-tools context files.
%prep
%autosetup -p1 -n %{srcname}-%{version}
%generate_buildrequires
%pyproject_buildrequires
%build
%pyproject_wheel
%install
%pyproject_install
%pyproject_save_files tpm2_pytss
%check
%if %{with testsuite}
%pyproject_check_import
%pytest --import-mode=append -k "not test_tools_decode_tpms_nv_public" -n %{_smp_build_ncpus}
%endif
%files -n python3-%{srcname} -f %{pyproject_files}
%doc README.md
%changelog
* Wed Sep 20 2023 Wang Guodong <gordonwwang@tencent.com> - 1.2.0-7
- Rebuilt for python-pytest-forked
* Tue Sep 19 2023 OpenCloudOS Release Engineering <releng@opencloudos.tech> - 1.2.0-6
- Rebuilt for python 3.11
* Fri Sep 08 2023 OpenCloudOS Release Engineering <releng@opencloudos.tech> - 1.2.0-5
- Rebuilt for OpenCloudOS Stream 23.09
* Fri Aug 18 2023 cunshunxia <cunshunxia@tencent.com> - 1.2.0-4
- Rebuilt for tpm2-tss 4.0.1
* Fri Apr 28 2023 OpenCloudOS Release Engineering <releng@opencloudos.tech> - 1.2.0-3
- Rebuilt for OpenCloudOS Stream 23.05
* Fri Mar 31 2023 OpenCloudOS Release Engineering <releng@opencloudos.tech> - 1.2.0-2
- Rebuilt for OpenCloudOS Stream 23
* Wed Dec 21 2022 Shuo Wang <abushwang@tencent.com> - 1.2.0-1
- initial build
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。