1 Star 0 Fork 5

gordonwwang/python-tpm2-pytss

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-tpm2-pytss.spec 2.83 KB
一键复制 编辑 原始数据 按行查看 历史
gordonwwang 提交于 2023-09-20 16:20 . Rebuit for py311
%global srcname tpm2-pytss
# open this flag in the future
%bcond_with testsuite
Summary: TPM 2.0 TSS Bindings for Python
Name: python-%{srcname}
Version: 1.2.0
Release: 7%{?dist}
License: BSD-2-Clause
URL: https://github.com/tpm2-software/tpm2-pytss
Source: %{pypi_source %{srcname}}
Patch3001: python-tpm2-pytss-1.2.0-openssl.patch
BuildRequires: python3-devel python3-pytest python3-pytest-xdist tpm2-tss-devel gcc
%if %{with testsuite}
BuildRequires: swtpm tpm2-tools
%endif
%description
TPM2 TSS Python bindings for Enhanced System API (ESYS), Feature API (FAPI), Marshaling (MU),
TCTI Loader (TCTILdr) and RC Decoding (rcdecode) libraries. It also contains utility methods
for wrapping keys to TPM 2.0 data structures for importation into the TPM, unwrapping keys
and exporting them from the TPM, TPM-less makecredential command and name calculations, TSS2
PEM Key format support, importing Keys from PEM, DER and SSH formats, conversion from tpm2-tools
based command line strings and loading tpm2-tools context files.
%package -n python3-%{srcname}
Summary: %{summary}
%description -n python3-%{srcname}
TPM2 TSS Python bindings for Enhanced System API (ESYS), Feature API (FAPI), Marshaling (MU),
TCTI Loader (TCTILdr) and RC Decoding (rcdecode) libraries. It also contains utility methods
for wrapping keys to TPM 2.0 data structures for importation into the TPM, unwrapping keys
and exporting them from the TPM, TPM-less makecredential command and name calculations, TSS2
PEM Key format support, importing Keys from PEM, DER and SSH formats, conversion from tpm2-tools
based command line strings and loading tpm2-tools context files.
%prep
%autosetup -p1 -n %{srcname}-%{version}
%generate_buildrequires
%pyproject_buildrequires
%build
%pyproject_wheel
%install
%pyproject_install
%pyproject_save_files tpm2_pytss
%check
%if %{with testsuite}
%pyproject_check_import
%pytest --import-mode=append -k "not test_tools_decode_tpms_nv_public" -n %{_smp_build_ncpus}
%endif
%files -n python3-%{srcname} -f %{pyproject_files}
%doc README.md
%changelog
* Wed Sep 20 2023 Wang Guodong <gordonwwang@tencent.com> - 1.2.0-7
- Rebuilt for python-pytest-forked
* Tue Sep 19 2023 OpenCloudOS Release Engineering <releng@opencloudos.tech> - 1.2.0-6
- Rebuilt for python 3.11
* Fri Sep 08 2023 OpenCloudOS Release Engineering <releng@opencloudos.tech> - 1.2.0-5
- Rebuilt for OpenCloudOS Stream 23.09
* Fri Aug 18 2023 cunshunxia <cunshunxia@tencent.com> - 1.2.0-4
- Rebuilt for tpm2-tss 4.0.1
* Fri Apr 28 2023 OpenCloudOS Release Engineering <releng@opencloudos.tech> - 1.2.0-3
- Rebuilt for OpenCloudOS Stream 23.05
* Fri Mar 31 2023 OpenCloudOS Release Engineering <releng@opencloudos.tech> - 1.2.0-2
- Rebuilt for OpenCloudOS Stream 23
* Wed Dec 21 2022 Shuo Wang <abushwang@tencent.com> - 1.2.0-1
- initial build
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/gordonwwang/python-tpm2-pytss.git
git@gitee.com:gordonwwang/python-tpm2-pytss.git
gordonwwang
python-tpm2-pytss
python-tpm2-pytss
master

搜索帮助