Fetch the repository succeeded.
This action will force synchronization from src-openEuler/perl-Module-Mask, which will overwrite any changes that you have made since you forked the repository, and can not be recovered!!!
Synchronous operation will process in the background and will refresh the page when finishing processing. Please be patient.
%global _empty_manifest_terminate_build 0
Name: perl-Module-Mask
Version: 0.06
Release: 1
Summary: Pretend certain modules are not installed
License: GPL+ or Artistic
Group: Development/Libraries
URL: http://search.cpan.org/dist/Module-Mask/
Source0: http://www.cpan.org/authors/id/M/MA/MATTLAW/Module-Mask-%{version}.tar.gz
BuildArch: noarch
BuildRequires: perl >= 1:v5.8.0
BuildRequires: perl-generators
BuildRequires: perl(Module::Build)
BuildRequires: perl(Module::Util) >= 1.00
BuildRequires: perl(Scalar::Util) >= 1.01
BuildRequires: perl(Test::More)
BuildRequires: perl(Test::Pod) >= 1.14
BuildRequires: perl(Test::Pod::Coverage) >= 1.04
Requires: perl(Module::Util) >= 1.00
Requires: perl(Scalar::Util) >= 1.01
Requires: perl(Test::Pod) >= 1.14
Requires: perl(Test::Pod::Coverage) >= 1.04
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
%description
Sometimes you need to test what happens when a given module is not
installed. This module provides a way of temporarily hiding installed
modules from perl's require mechanism. The Module::Mask object adds itself
to @INC and blocks require calls to restricted modules.
%package help
Summary : Pretend certain modules are not installed
Provides: perl-Module-Mask-doc
%description help
Sometimes you need to test what happens when a given module is not
installed. This module provides a way of temporarily hiding installed
modules from perl's require mechanism. The Module::Mask object adds itself
to @INC and blocks require calls to restricted modules.
%prep
%setup -q -n Module-Mask-%{version}
%build
export PERL_MM_OPT=""
%{__perl} Build.PL --installdirs=vendor
./Build
%install
export PERL_MM_OPT=""
rm -rf $RPM_BUILD_ROOT
./Build install --destdir=$RPM_BUILD_ROOT --create_packlist=0
find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \;
%{_fixperms} $RPM_BUILD_ROOT/*
pushd %{buildroot}
touch filelist.lst
if [ -d usr/bin ];then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ];then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ];then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib ];then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
popd
mv %{buildroot}/filelist.lst .
%check
./Build test
%clean
rm -rf $RPM_BUILD_ROOT
%files -f filelist.lst
%defattr(-,root,root,-)
%doc Changes META.json README
%{perl_vendorlib}/*
%files help
%{_mandir}/*
%changelog
* Tue Oct 19 2021 Heyitao <heyitao@uniontech.com> 0.06-1
- Package init
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。