1 Star 0 Fork 2

可乐君/project-gameface

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
克隆/下载
build.spec 1.34 KB
一键复制 编辑 原始数据 按行查看 历史
bit-dome 提交于 2023-05-10 10:26 . fix: rename build.spec
# -*- mode: python ; coding: utf-8 -*-
from pathlib import Path
import mediapipe
import customtkinter
block_cipher = None
mp_init = Path(mediapipe.__file__)
mp_modules = Path(mp_init.parent,"modules")
ctk_init = Path(customtkinter.__file__)
ctk_modules = Path(ctk_init.parent,"modules")
app = Analysis(
['run_app.py'],
pathex=[],
binaries=[],
datas=[(mp_modules.as_posix(), 'mediapipe/modules'),
('assets','assets'),
('configs','configs'),
(ctk_init.parent.as_posix(), 'customtkinter')],
hiddenimports=[],
hookspath=[],
hooksconfig={},
runtime_hooks=[],
excludes=[],
win_no_prefer_redirects=False,
win_private_assemblies=False,
cipher=block_cipher,
noarchive=False,
)
pyz_app = PYZ(app.pure, app.zipped_data, cipher=block_cipher)
exe_app = EXE(
pyz_app,
app.scripts,
[],
exclude_binaries=True,
name='run_app',
debug=False,
bootloader_ignore_signals=False,
strip=False,
upx=True,
console=False,
disable_windowed_traceback=False,
argv_emulation=False,
target_arch=None,
codesign_identity=None,
entitlements_file=None,
)
coll = COLLECT(
exe_app,
app.binaries,
app.zipfiles,
app.datas,
strip=False,
upx=True,
upx_exclude=[],
name='project_gameface',
)
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
Python
1
https://gitee.com/colaKun/project-gameface.git
git@gitee.com:colaKun/project-gameface.git
colaKun
project-gameface
project-gameface
main

搜索帮助