代码拉取完成,页面将自动刷新
同步操作将从 notify/新月杀 强制同步,此操作会覆盖自 Fork 仓库以来所做的任何修改,且无法恢复!!!
确定后同步将在后台操作,完成时将刷新页面,请耐心等待。
{
description = "Sanguosha (a.k.a. Legend of Three Kingdoms, LTK) written in Qt and Lua.";
inputs = {
nixpkgs.url = "github:nixos/nixpkgs/nixos-22.11";
};
outputs = { self, nixpkgs }: {
defaultPackage.x86_64-linux =
with import nixpkgs { system = "x86_64-linux"; };
stdenv.mkDerivation {
name = "freekill";
version = "0.1.6";
src = self;
buildInputs = with qt6; [
qtbase
qtdeclarative
qt5compat
qtmultimedia
qttools
sqlite
swig
openssl
flex
bison
readline
libgit2
lua5_4
];
nativeBuildInputs = [ cmake qt6.wrapQtAppsHook ];
postPatch = ''
substituteInPlace src/CMakeLists.txt --replace "LUA_LIB lua5.4" "LUA_LIB lua";
'';
};
};
}
此处可能存在不合适展示的内容,页面不予展示。您可通过相关编辑功能自查并修改。
如您确认内容无涉及 不当用语 / 纯广告导流 / 暴力 / 低俗色情 / 侵权 / 盗版 / 虚假 / 无价值内容或违法国家有关法律法规的内容,可点击提交进行申诉,我们将尽快为您处理。