1 Star 0 Fork 4

金帅羽/python-paho-mqtt

加入 Gitee
与超过 1200万 开发者一起发现、参与优秀开源项目,私有仓库也完全免费 :)
免费加入
文件
该仓库未声明开源许可证文件(LICENSE),使用请关注具体项目描述及其代码上游依赖。
克隆/下载
python-paho-mqtt.spec 3.06 KB
一键复制 编辑 原始数据 按行查看 历史
金帅羽 提交于 2024-10-24 14:17 . Update to 2.1.0
%global _empty_manifest_terminate_build 0
Name: python-paho-mqtt
Version: 2.1.0
Release: 1
Summary: MQTT version 5.0/3.1.1 client class
License: EPL-1.0
URL: http://eclipse.org/paho
Source0: https://files.pythonhosted.org/packages/39/15/0a6214e76d4d32e7f663b109cf71fb22561c2be0f701d67f93950cd40542/paho_mqtt-2.1.0.tar.gz
BuildArch: noarch
%description
This library provides a client class which enable applications to connect to
an MQTT broker to publish messages, and to subscribe to topics and receive
published messages. It also provides some helper functions to make publishing
one off messages to an MQTT server very straightforward.
%package -n python3-paho-mqtt
Summary: MQTT version 5.0/3.1.1 client class
Provides: python-paho-mqtt
BuildRequires: python3-devel
BuildRequires: python3-setuptools
%description -n python3-paho-mqtt
This library provides a client class which enable applications to connect to
an MQTT broker to publish messages, and to subscribe to topics and receive
published messages. It also provides some helper functions to make publishing
one off messages to an MQTT server very straightforward.
%package help
Summary: Development documents and examples for paho-mqtt
Provides: python3-paho-mqtt-doc
%description help
This library provides a client class which enable applications to connect to
an MQTT broker to publish messages, and to subscribe to topics and receive
published messages. It also provides some helper functions to make publishing
one off messages to an MQTT server very straightforward.
%prep
%autosetup -n paho_mqtt-%{version}
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-paho-mqtt -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed Oct 30 2024 jinshuaiyu <jinshuaiyu@kylinos.cn> - 2.1.0-1
- Update to 2.1.0
- Make transition from 1.x to 2.x version smoother
- Fix "protocol" property
- Fix publish() a bytearray payload
- Fix some type annotations
- Fix loop_stop() not stopping thread when called from callback
- Fix some documentation errors
- Add support for Unix socket
- Fix flaky test
* Wed Sep 14 2022 Qiao Jijun <qiaojijun@kylinos.cn> - 1.6.1-1
- Update to 1.6.1
* Mon Sep 06 2021 Python_Bot <Python_Bot@openeuler.org> - 1.5.1-1
- Package Init
马建仓 AI 助手
尝试更多
代码解读
代码找茬
代码优化
1
https://gitee.com/all233/python-paho-mqtt.git
git@gitee.com:all233/python-paho-mqtt.git
all233
python-paho-mqtt
python-paho-mqtt
master

搜索帮助